English Server Move

50 replies
Goto Page
To the start Previous 1 2 3 Next To the start
13.06.20 12:17:11 am
Up
DC
Admin
Offline Off
@user MikuAuahDark: Changed those links to HTTPS. My long term goal would be to make HTTPS default. Not sure if I can enable HSTS. I still have to allow HTTP for CS2D because it does not support HTTPS unfortunately (it's required for avatar downloads etc)

Also fixed some errors on the USGN page and added files_pub with the map format spec

I think mails are not working in general right now (required for registration and password lost functions. well be fixed ASAP).

Edit
Mails should work now
edited 1×, last 13.06.20 01:36:06 am
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
13.06.20 06:35:46 am
Up
MikuAuahDark
User
Offline Off
This one still doesn't

user DC has written:
I still have to allow HTTP for CS2D because it does not support HTTPS unfortunately

I think you can update CS2D which sent special, private header to every request in UnrealSoftware and let the UnrealSoftware web server check for the presence of that header. If the header is present, allow normal HTTP request. Otherwise, issue 302 redirect to HTTPS website. You can also check for the User-Agent header, like if it's a browser then force it to visit the HTTPS website by issuing 302 redirect to the HTTPS website.

You can choose to send Strict-Transport-Security regardless or only send it if the header you wanted is not present.

EDIT: User-Agent
EDIT2: Oh I forgot to mention that all download links in cs2d.com still points to non-HTTPS.
edited 2×, last 13.06.20 06:50:22 am
file cs2d LuaJIT for Dedicated Server (11) JIT POWER! | Know your Lua errors! | Draw stuff at Pixelize Art --xx-- server!
13.06.20 11:43:45 am
Up
The Dark Shadow
User
Offline Off
@user DC: Can't you create a system that automatically redirects you to HTTPS from HTTP?
13.06.20 11:59:54 am
Up
BcY
Reviewer
Offline Off
@user The Dark Shadow: it can be done with htaccess
Kgb2d Community - Since 2012
13.06.20 12:34:50 pm
Up
Gaios
Security Supporter
Offline Off
user The Dark Shadow has written:
@user DC: Can't you create a system that automatically redirects you to HTTPS from HTTP?

@user The Dark Shadow:
user DC has written:
Not sure if I can enable HSTS. I still have to allow HTTP for CS2D because it does not support HTTPS unfortunately (it's required for avatar downloads etc)
14.06.20 07:44:40 am
Up
Polar
User
Offline Off
I just saw players playing online for 2 days, you can see it ,this happened since there was DNS change, but from what I see, it affects brazilian players like @user RyAnn:,@user null11:, @user codigos2d: & @user SenseiSz:.
I don't know if it's a mistake or what, but it's to be aware
What the F.A.Q.?| ∗ faqduLLAH
15.06.20 06:21:23 pm
Up
Medeiros
User
Offline Off
Since this update, many CS2D servers can't be joined and players get stuck at the "verifying USGN login" screen.

I'm almost certain that it's not a problem on my end because 1) there's servers that I can join and 2) the ones which are affected by this almost always had players on them and now they're always at 0 players. And yes, even though CS2D doesn't have as many players as it once did, there's still at least 1 or 2 Standard servers that fill up daily... well, until this update.

--- Edit ---
Hmmm, weird, I can now enter on those specific servers by logging off of my USGN account, and one of them (specifically [Q] Complex de_dust) now shows a player count while it was always "0" when I was logged in.
However, once I log back in, I still get the same issue, can't join the servers.
And yes, I checked before writing this post and after this edit; my usgn.dat file starts with this line:
Code:
1
81.169.236.243|usgn.de

I just find it odd that there's servers which I can join with my account and others that I can't, whereas before I could.
edited 1×, last 15.06.20 06:32:06 pm
15.06.20 07:58:45 pm
Up
DC
Admin
Offline Off
@user Medeiros: It's a known issue. I'm working on a fix.

@user Polar: Thanks. Guess I know why this is happening. Will be fixed too.
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
15.06.20 07:59:58 pm
Up
TrialAndError
User
Offline Off
I have the same problem as @user Medeiros:. I can't even join my own dedicated server and test my scripts anymore, it just gets stuck on "Verifying USGN login" and in the server console, it says that I'm "not logged in".

Edit: Okay, DC responded as I was typing so we'll be waiting
15.06.20 09:03:33 pm
Up
Polar
User
Offline Off
user TrialAndError, check the first post of this thread and do what user DC said
What the F.A.Q.?| ∗ faqduLLAH
15.06.20 09:16:54 pm
Up
Medeiros
User
Offline Off
@user Polar: what him and I reported are different issues than the one that's fixed by what's in the first post.
Thanks for looking into it, user DC!
15.06.20 10:24:33 pm
Up
DC
Admin
Offline Off
Okay. I think login verification should be fixed now.
Same for people staying in the "playing XYZ"-state forever.

Please let me know if it works for you or if you still have problems!
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
15.06.20 10:52:18 pm
Up
reiszorro
User
Offline Off
@user DC: still I have verification problem I cant join servers when my usgn logged
Ah Eskiler Ah
15.06.20 11:00:29 pm
Up
DC
Admin
Offline Off
You're right. Oh no.
Okay... back to work.

Edit:
Okay, had another really stupid bug in there. Should be fine now!
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
16.06.20 02:49:00 pm
Up
MikuAuahDark
User
Offline Off
CS2D version checking still fails.
Log >


When the version check fails, CS2D stuck at "trying to login". Restarting CS2D and skipping the version checking as fast as possible allows me to login in-game, but USGN verification still fails.
file cs2d LuaJIT for Dedicated Server (11) JIT POWER! | Know your Lua errors! | Draw stuff at Pixelize Art --xx-- server!
16.06.20 02:58:02 pm
Up
Mami Tomoe
User
Offline Off
16.06.20 07:45:00 pm
Up
DC
Admin
Offline Off
@user MikuAuahDark: You must still have the wrong (old) USGN IP in your sys/usgn.dat (see my edit in the thread). This must be updated for client AND server!

Or your connection to the new server is blocked by something for some reason (I can't help then because it's not on my end. it works for other people)
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
17.06.20 05:31:36 am
Up
MikuAuahDark
User
Offline Off
Of course I've updated my usgn.dat. I'd be very dumb if I didn't do that in the first place prior reporting.

Also everything was work prior the server move and as user DC said before, rewriting the USGN masterserver. CS2D version checking and USGN verification works prior this. I'd really love to solve this problem together, but I also understand USGN masterserver code is something that shouldn't be known by normal user like me so our best bet is guessing.
file cs2d LuaJIT for Dedicated Server (11) JIT POWER! | Know your Lua errors! | Draw stuff at Pixelize Art --xx-- server!
17.06.20 01:07:57 pm
Up
The Dark Shadow
User
Offline Off
Why we are receiving unexpected USGN Masterserver messages?
18.06.20 07:36:34 pm
Up
DC
Admin
Offline Off
@user The Dark Shadow: You normally shouldn't get unexpected USGN masterserver messages. When does this happen?

@user MikuAuahDark: Sounds super weird. I'll try to find out what's going wrong but it's complicated to do so because it works fine when I use CS2D with USGN on my side. It's weird that you're also getting these unexpected masterserver messages. That shouldn't happen.
www.UnrealSoftware.de | www.CS2D.com | www.CarnageContest.com | Use the forum & avoid PMs!
To the start Previous 1 2 3 Next To the start